Bug report #14435

Rule-based labeling and the Data defined placement options are not working together

Added by Martin Höpke over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22414

Description

After setting "Rule-based labeling" to layer (new feature since QGIS 2.12), the data defined labeling position is not working any more.
After going back to "Show labels for this layer", everything works fine.

History

#1 Updated by R. R. over 4 years ago

Same here, as a workaround I use the 'Rotate Point Symbols' tool (data defined angle) to rotate rule-based labels (data defined rotation).

#2 Updated by Giovanni Manghi over 4 years ago

  • OS version deleted (17.2)
  • Operating System deleted (Mint)
  • Priority changed from High to Normal
  • Category set to Labelling

#3 Updated by R. R. over 4 years ago

Seems to be fixed in master.

#4 Updated by R. R. over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF