Bug report #14426

Zoom to layer behaves really weird when using a filter on a Shape file

Added by Casper Børgesen about 4 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Unknown
Affected QGIS version:2.14.0 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22406

Description

Steps to reproduce:

1. Open QGIS.
2. Open Shape file with atleast one attribute with varying values.
3. Show the layer.
4. Zoom to layer.
5. Zoom in on a feature.
6. Create a filter (Right click layer, select filter, filter on something).
7. Zoom to layer.

Now what happens for me is that it doesn't zoom to layer. When dragging the map (using the hand) the view just jumps back when I release the drag.

I would expect the zoom to layer was working and that I would be able to resume working normally with QGIS afterwards.

This occurs both in the latest 2.14 x64 Windows release and in MASTER 81be559.

Associated revisions

Revision 5bb25d89
Added by Salvatore Larosa about 4 years ago

Fix #14426 - Zoom to layer behaves really weird when using a filter on a Shape file:

Fix extent for OGR provider, followup 9fb7819

Revision 9842dd74
Added by Salvatore Larosa about 4 years ago

Fix #14426 - Zoom to layer behaves really weird when using a filter on a Shape file:

Fix extent for OGR provider, followup 9fb7819

(cherry-picked from 5bb25d8917dc0d494ae46c035f8e019f448c60fb)

History

#1 Updated by Salvatore Larosa about 4 years ago

  • Status changed from Open to Closed

#2 Updated by Jürgen Fischer over 2 years ago

  • Category set to Unknown

Also available in: Atom PDF