Bug report #14308

TestVectorLayerJoinBuffer hangs if database is not available

Added by Sandro Santilli over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Sandro Santilli
Category:Tests Suite
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No

Description

As with #14269, this other test is hanging due to missing database:

ctest -V -R vectorlayerjoin
...
102: QDEBUG : TestVectorLayerJoinBuffer::initTestCase() src/providers/postgres/qgspostgresconn.cpp: 207: (QgsPostgresConn) [0ms] New PostgreSQL connection for dbname='qgis_test' host=localhost port=5432 user='postgres' password='postgres' sslmode=disable
102: credentials for dbname='qgis_test' host=localhost port=5432 user='postgres' password='postgres' sslmode=disable
102: message: FATAL:  database "qgis_test" does not exist
102:

And sits there forever.

Associated revisions

Revision 6365eb7e
Added by Sandro Santilli over 1 year ago

Do not hard-code database connection parameters

Rely on libpq defaults instead (overridable via environment)

Fixes #14308

History

#1 Updated by Sandro Santilli over 1 year ago

  • Status changed from Open to In Progress

#2 Updated by Sandro Santilli over 1 year ago

  • Pull Request or Patch supplied changed from No to Yes

Ready for test by Travis: https://github.com/qgis/QGIS/pull/2793

#3 Updated by Sandro Santilli over 1 year ago

  • Status changed from In Progress to Closed

#4 Updated by Sandro Santilli over 1 year ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF