Bug report #14281

Embedding layers does not work

Added by Sebastian Dietrich about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Hugo Mercier
Category:Project Loading/Saving
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22275

Description

When embedding a simple layer from a project, I can select the layer I want to embed, but it does not show up in the legend or the canvas. There is no error message either.

This is a regression, since it worked in 2.12

Reproduce:
  • Create new project
  • Create a memory layer
  • Save the project as TestForEmbedding.qgs
  • Create new project
  • Embed the layer from TestForEmbedding.qgs
  • Result
    • Expected: The (empty) layer is shown in the legend
    • Actual: Nothing

I attached a sample project so you can skip the first three steps.

TestForEmbedding.qgs - Sample project containing a memory layer for embedding (7.17 KB) Sebastian Dietrich, 2016-02-11 03:34 AM

Associated revisions

Revision 6bbe3b93
Added by Hugo Mercier about 4 years ago

Fix DependencySorter.sortedLayerIds. Fixes #14281

History

#2 Updated by Hugo Mercier about 4 years ago

  • Assignee set to hartmut-tschauner-gmail-com -

Thanks, I'll try to have a look soon

#3 Updated by Sebastian Dietrich about 4 years ago

  • Assignee changed from hartmut-tschauner-gmail-com - to Hugo Mercier
@Hugo Mercier
Good. I think you mistakenly assigned somebody else here and re-assigned the issue to you. If that is not correct, please let me know or re-assign it again.

#4 Updated by Hugo Mercier about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF