Bug report #14252

Cannot Save or Edit Existing .Shp Files

Added by Daniel Hart over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.12.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:22248

Description

I'm having a problem doing any of the following

  • Saving edits to existing .shp files
  • Converting other file types to .shp files

All other conversions appear to be working fine, but I am unable to save anything as a shape file. I have tried this on multiple versions (2.8.6 and 2.12.3, both 32 and 64 bit installs). I'm working on a 64bit Windows 7 machine.

Below is an example of the returned error (in this case a conversion, though the same error displays for edits):

Export to vector file failed.
Error: Feature write errors:
Feature creation error (OGR error: Error in psSHP->sHooks.FSeek() while writing object to .shp file.)

History

#1 Updated by Saber Razmjooei over 4 years ago

  • Status changed from Open to Feedback

Is your file readable by any chance?

#2 Updated by Giovanni Manghi over 4 years ago

  • Category set to Vectors

seems much like a local issue... please remove/disable any 3rd party plugin and try again. If still fail try also another system, to exclude local issues completely. Thanks.

#3 Updated by Antonio Locandro over 4 years ago

Can you provide a test shapefile that fails to you so we can check? Very difficult without an actual case to review

#4 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback. Please reopen if necessary.

Also available in: Atom PDF