Bug report #14249

Error while saving shape file

Added by Pierre M about 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.10.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22245

Description

Hi,

I use a QGis 2.10 version, X64 on Windows installed with Osgeo4W.

I'll try to explain the bug.

I work on a map, with a shape file of polygons. They are not really complex, nor numerous (25). I got id, DOSSIER, NOM_OPERAT, PRIORITE, COMMENTA, DATE_MAJ, SOURCE, LIBELLE_X, LIBELLE_Y fields and SURF_HA which is a virtual field.

Friday, it took me 5 min to save the file each time I modify a vertex.

Today, I update my id field with the expression "$id". Then, my shape file looks like a totally mess (look at the imgur album : http://imgur.com/a/noSM2). The LIBELLE_X, LIBELLE_Y fields have disappeard, the DOSSIER field which used to be null is now partially fulled, the NOM_OPERAT are truncated, fulled in a completelly non-sense manner. As for PRIORITE, DATE_MAJ.

I've rewrote the attributes. Everything was saved. Then I recreated the LIBELLE_X, LIBELLE_Y attributes and saved. And everything was messed up.

(see screenshot here : http://i.imgur.com/E3vA0LX.png?1).

So, what happened ? How could this happen ? What information may I add to help solving the problem ? I will try without plug in to see if things work.

PS. Sorry but I don't have the genuine files, and the data are quite sensitive.

History

#1 Updated by Giovanni Manghi about 4 years ago

  • Status changed from Open to Feedback
  • Category set to Vectors

Please test the latest fixes installing the "master" version of qgis using the osgeo4w installer, then report back.

Also you may want to use always the "ltr" (long term release) during your work, as are the versions known to be more stable and that get regularly bug fixes. The ltr is now 2.8.* but soon will be the 2.14.*

#2 Updated by Giovanni Manghi almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

closing for lack of feedback and because seems similar/related to #14711

Also available in: Atom PDF