Bug report #14248

Debian build failure.

Added by Andy Wood over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:Linux amd64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No

Description

A clean build on Debian testing fails at the start (problem has been around for a few days):

dpkg-source --before-build qgis_src
fakeroot debian/rules clean
dh clean --with python2 --parallel --builddirectory=debian/build
dh: No compatibility level specified in debian/compat
dh: This package will soon FTBFS; time to fix it!
dh: Compatibility levels before 4 are no longer supported (level 1 requested)
debian/rules:214: recipe for target 'clean' failed
make: *** [clean] Error 2
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2

Related issues

Related to QGIS Application - Bug report #14289: QGIS packaging problem (master) - again Closed 02/12/2016

Associated revisions

Revision 41ac88ad
Added by Jürgen Fischer over 1 year ago

debian packaging: fix templates (fixes #14248)

History

#1 Updated by Jürgen Fischer over 1 year ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Refer to Building debian packages (ie. you need a changelog entry for stretch to get 9 into debian/compat from debian/compat.in)

#2 Updated by Andy Wood over 1 year ago

  • Status changed from Closed to Reopened

This does not seem to work as documented any more:

$ git clone git://github.com/qgis/Quantum-GIS.git qgis_src
Cloning into 'qgis_src'...
remote: Counting objects: 339925, done.
remote: Compressing objects: 100% (172/172), done.
remote: Total 339925 (delta 83), reused 2 (delta 2), pack-reused 339749
Receiving objects: 100% (339925/339925), 1.15 GiB | 7.08 MiB/s, done.
Resolving deltas: 100% (267653/267653), done.
Checking connectivity... done.
Checking out files: 100% (13108/13108), done.
$ cd qgis_src
$ dch -l ~stretch --force-distribution --distribution stretch "stretch build" 
dch warning: Recognised distributions are: unstable, testing, stable,
oldstable, experimental, {testing-,stable-,oldstable-,}proposed-updates,
{testing,stable,oldstable}-security, wheezy-backports, jessie-backports and UNRELEASED.
Using your request anyway.
$ dpkg-buildpackage -us -uc -b
dpkg-buildpackage: source package qgis
dpkg-buildpackage: source version 2.13.0~stretch1
dpkg-buildpackage: source distribution stretch
dpkg-buildpackage: source changed by Andy Wood <###>
dpkg-buildpackage: host architecture amd64
 dpkg-source --before-build qgis_src
 fakeroot debian/rules clean
dh clean --with python2 --parallel --builddirectory=debian/build
dh: No compatibility level specified in debian/compat
dh: This package will soon FTBFS; time to fix it!
dh: Compatibility levels before 4 are no longer supported (level 1 requested)
debian/rules:214: recipe for target 'clean' failed
make: *** [clean] Error 2
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2

If you `rm debian/compat` and then dch and dpkg-buildpackage, does it still work for you?

#3 Updated by Jürgen Fischer over 1 year ago

  • Status changed from Reopened to Closed

#4 Updated by Andy Wood over 1 year ago

  • Status changed from Closed to Reopened

Thank you for the update, however I fear it has introduced another problem:

dpkg-source: error: syntax error in qgis_src/debian/control at line 76: duplicate field Conflicts found
dpkg-buildpackage: error: dpkg-source --before-build qgis_src gave error exit status 25

Package: qgis
[...]
Conflicts: uim-qt3
[...]
Conflicts: uim-qt3, qgis-plugin-grass (<< 1:2.13.0+git20160204)

#5 Updated by Andy Wood over 1 year ago

  • Status changed from Reopened to Closed

Seems to be fixed now.

Also available in: Atom PDF