Bug report #14233

Spatialite view, identify results, view feature form shows wrong result

Added by Gerhard Spieles over 1 year ago. Updated 9 months ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No

Description

open a feature form shows always the first row in a spatialite view
jpg is attached

spatialite_view_featur_form_wrong_result.jpg (288 KB) Gerhard Spieles, 02/04/2016 06:36 AM

view_spatialite_qgis2.12_objects_visibilty_ok.jpg (197 KB) Gerhard Spieles, 02/25/2016 12:52 AM

view_spatialite_qgis2.13a934b01_objects_visibilty_no.jpg (227 KB) Gerhard Spieles, 02/25/2016 12:52 AM

spatialite_view.png (32.4 KB) Pieter Brusselman, 10/02/2016 01:41 PM


Related issues

Related to QGIS Application - Bug report #13482: only first element selectable in spatialite layer Open 10/01/2015

History

#1 Updated by Giovanni Manghi over 1 year ago

  • OS version deleted (7)
  • Category set to Vectors
  • Priority changed from High to Severe/Regression
  • Operating System deleted (windows)

Confirmed also as a regression (is ok at least on 2.8.6).

#2 Updated by Martin Dobias over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

#3 Updated by Gerhard Spieles over 1 year ago

Tested it with QGIS 2.13 a934b01. As result, no objects are visible in the loeded view since the latest master.
jpgs are attached.

#4 Updated by Martin Dobias over 1 year ago

  • Status changed from Reopened to Closed

#5 Updated by Pieter Brusselman 9 months ago

Martin Dobias wrote:

Fixed in 42d88848f3010365d2c9fcf84b3a8ed5d52749a1

It seems that in QGIS 2.16.2 this problem still exists. When selecting a feature it shows the correct values. But when you open the feature form, it always gives the values of the feature with the first ID.

Also available in: Atom PDF