Feature request #1422

Add ability to use socks5 proxy

Added by cfarmer - almost 12 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Web Services clients/WMS
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:11482

Description

The attached diff adds the ability to use socks5 proxying to qgis for users working behind one of these proxy types. The fix also contains changes to the python plugin installer. Changes should not affect anything that does not explicitly recognize the change, so wms provider etc will not be affected...

bug_1422_fix.diff Magnifier (17.1 KB) cfarmer -, 2008-11-24 02:15 AM

bug_1422_fix_2.diff Magnifier (1.44 KB) cfarmer -, 2008-11-24 04:21 PM

History

#1 Updated by Borys Jurgiel almost 12 years ago

Plugin Installer reads proxyType from QSettings now (from rev 9700). It recognizes following values for PyQt 4.3: 'Socks5Proxy', 'NoProxy', 'HttpProxy' and their integer equivalents. For PyQt 4.4 it supports also values 'HttpCachingProxy' and 'FtpCachingProxy' and their integer equivalents. In case of any unsupported value, the DefaultProxy is used.

I don't implement frontend for setting it due to the gui freeze.

#2 Updated by cfarmer - almost 12 years ago

This new diff is likely a better way to implement the above changes. I have not made any new changes to the plugin installer, as Borys has already applied the above fix, plus some excellent extras!

#3 Updated by Giovanni Manghi over 11 years ago

Has this already been implemented as it seems to me?

Closing?

#4 Updated by Giovanni Manghi over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Closing as it seems to me that was a duplicate of #1374. Reopen if necessary.

Also available in: Atom PDF