Bug report #14206

jp2 raster displayed as black background in QGISmaster 8dafa63,

Added by Gerhard Spieles almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:22208

Description

jp2 images are shown in black with underlying different colours in QGIS-master.
The same images are correct displayed in QGIS 2.12

jpg is attached.

2.13_master_can_not_display_jp2_raster.jpg (101 KB) Gerhard Spieles, 2016-02-01 03:16 AM

without_lib_gdal_ecw_jp2.jpg (178 KB) Gerhard Spieles, 2016-02-03 03:34 AM

with_lib_gdal_ecw_jp2.jpg (227 KB) Gerhard Spieles, 2016-02-03 03:34 AM

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Priority changed from High to Severe/Regression
  • Status changed from Open to Feedback

Please attach sample data.

#2 Updated by Gerhard Spieles almost 5 years ago

sample attached

#3 Updated by Gerhard Spieles almost 5 years ago

file is to large

#4 Updated by Giovanni Manghi almost 5 years ago

send it to me (giovanni dot manghi at naturalgis dot pt) or use dropbox (or similar service). Thanks!

#5 Updated by Giovanni Manghi almost 5 years ago

  • Priority changed from Severe/Regression to Normal
  • OS version deleted (7)
  • Operating System deleted (win)

Gerhard Spieles wrote:

file is to large

just tested on Windows/Osgeo4w on 2.8.6, 2.12.3 and master, and in all three the raster does not open correctly. What driver is used in your system (where the raster shows ok)?

#6 Updated by Gerhard Spieles almost 5 years ago

The driver is it!
you need to install the lib gdal-ecw and the problem is solved.
jpgs are attached.

It should be good, when in the standard OSGeOo-Installation, lib gdal-ecw is included

Thank`s Giovanni

#7 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF