Bug report #14190

shapefile vector writer: datetime field saved as date resulting in data loss of time

Added by Mathieu Pellerin - nIRV over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No

Description

QGIS' vector writer does not handle datetime field correctly when saving a shapefile. The field gets transformed into a date field, and the time data is loss.

Steps to reproduce
  1. Create a new project, add the attached test.gpx vector layer (pick the track_point layer)
  2. Open the layer properties window, notice the time field is a "datetime".
  3. Right-click on the layer, and select "save as..."
  4. Select the "ESRI Shapefile" format, and save the layer (make sure [x] add saved file to map is checked, it'll make the next step easier)
  5. Open the layer properties window of the saved shapefile layer which was added to the project
  6. Go in the Fields panel, and notice the time field is now of type "date" (you can then open the attribute window and confirm that the time information has been lost)

Since ESRI Shapefile does not support a DateTime field type, it should be transformed to a string to preserve data, not a date.

test.gpx (1.25 KB) Mathieu Pellerin - nIRV, 01/28/2016 06:14 PM

Associated revisions

Revision a3f03f02
Added by Jürgen Fischer over 1 year ago

vector file writer: fix saving of datetime values (fixes #14190)

History

#1 Updated by Jürgen Fischer over 1 year ago

  • Status changed from Open to Closed

Also available in: Atom PDF