Bug report #14175

QGIS crash after closing the file dialog

Added by Bernd Piepers about 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:2.12.2 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:22177

Description

After closing a file dialog, QGIS crash and show a minidump popup.
It is not possible to open a file, open a project or save a project without crash.
Even if the dialog is left with escape (without choosing a file) QGIS crashes.

It is possible to open files with the browser or with the file tree.
But this workaround doesn't work for the geo-reference dialog.

Tried with version 2.12.3 and with 2.8.4
(* 2.12.3 is missing in the selection 'Affected version' of the bug tracker page, therefore I selected 2.12.2)

How to repeat:
start QGIS, choose Ctrl-O (open file), press ESC (or choose one file)

History

#1 Updated by Bernd Piepers about 4 years ago

The dump file is 30 MB, seems to be to large to upload.

#2 Updated by Bernd Piepers about 4 years ago

max. size 5 MB

#3 Updated by Saber Razmjooei about 4 years ago

  • Priority changed from High to Normal
  • Status changed from Open to Feedback

I have tried and can't replicate your problem.
This could be due to a plugin. Could you run QGIS with no plugin (rename your .qgis2 plugin folder)?

#4 Updated by Giovanni Manghi almost 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback. Please reopen if necessary.

Also available in: Atom PDF