Bug report #14158

regression: default "save as" value for ESPR Shapefile prevents creation of .shp

Added by Mathieu Pellerin - nIRV over 1 year ago. Updated 3 days ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No

Description

Currently under master, the save as dialog sets the SHPT layer option to NULL for the ESPR Shapefile driver. This translates into the creation of a .dbf-only dataset. In previous versions of QGIS, I'm pretty sure the SHPT option was not set, as I have many times in the past saved KML files as shapefiles without having to modify layer options.

While it might be useful to expose the SHPT option, having "dbf-ony" option set by default is not good (understatement of the week :) ).

I have no idea when this regressed.

Associated revisions

Revision 5512d544
Added by Martin Dobias over 1 year ago

Fix regression in vector "save as" that saved shapefiles as .dbf only (fixes #14158)

History

#1 Updated by Mathieu Pellerin - nIRV over 1 year ago

One way to fix this is to remove the SHPT option altogether, since QGIS itself now allows to modify the geometry type.

#2 Updated by Martin Dobias over 1 year ago

  • Status changed from Open to Closed

#3 Updated by Jürgen Fischer 3 days ago

  • Category set to Unknown

Also available in: Atom PDF