Bug report #14043

feature rendering order not saved, settings lost when re-loading project

Added by Mathieu Pellerin - nIRV over 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Matthias Kuhn
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22054

Description

The newly-introduced feature rendering order setttings are not saved in the project file, leading to the settings being lost upon (re-)loading a project.

Steps to reproduce
  1. Create a new project, add a vector layer
  2. Open the properties window, go to symbology
  3. Set a feature rendering order
  4. Save the newly created project
  5. Close the project, and re-load it
  6. Open the properties window, go to symbology
  7. Notice the feature rendering order settings are gone

testproject.zip (311 KB) Mathieu Pellerin - nIRV, 2016-01-04 05:58 PM

Associated revisions

Revision 16aeb3f1
Added by Mathieu Pellerin - nIRV about 4 years ago

fix orderby not saved in several symbologies (fixes #14043)

Revision 614c84f2
Added by Matthias Kuhn about 4 years ago

Merge pull request #2636 from nirvn/orderby_fix

[rendering order] fix order setting not saved in rule-based symb. (fixes #14043)

History

#1 Updated by Matthias Kuhn about 4 years ago

  • Status changed from Open to Feedback

Can't reproduce with a shapefile and the default symbology apart from the rendering order.

#2 Updated by Mathieu Pellerin - nIRV about 4 years ago

Matthias, ok, it might have to do with the fact that the layer I was testing is a rule-based symbology.

I'm attaching a test project with a shapefile layer relying on rule-based symbology. Everytime I set rendering order, save the project, and re-load that project afterwards, the rendering order setting is lost.

Hope that'll help nail the issue.

#4 Updated by Anonymous about 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF