Bug report #14039

Trouble Installing qgis-plugin-grass, Dependency Issue

Added by Richard Carpenter almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.8.5 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:22052

Description

I'm trying to load QGIS and the additional programs that are recommended to install with it according to QGIS' installation instructions (http://www.qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu)... and some of the help I've been able to find here and elsewhere on the internet.

I am running Linux Mint 17.2 'Rafaela' on an Acer Aspire TimelineX 4830TG-6450, with an Intel i5 2430M chipset.

I was able to get past the unmet dependencies and key problems that commonly seem to occur with others, and was able to install 'qgis' and 'python-qgis'. However, I can not load 'qgis-plugin-grass'. When I try install it, I get this message:

The following packages have unmet dependencies:
qgis-plugin-grass : Depends: qgis (= 1:2.8.5+20trusty) but 1:2.8.5+20trusty-ubuntugis is to be installed
Depends: qgis-provider-grass (= 1:2.8.5+20trusty) but 1:2.8.5+20trusty-ubuntugis is to be installed
Depends: grass-core (< 7) but 7.0.1-1~exp1~trusty is to be installed
E: Unable to correct problems, you have held broken packages.

Can anyone assist me with getting this installed?

Thank you!
Rich C.

History

#1 Updated by Jürgen Fischer almost 5 years ago

  • Category changed from GRASS to Build/Install
  • Status changed from Open to Feedback

You might be mixing repositories. You should either have qgis.org/debian-ltr or qgis.org/ubuntugis-ltr, but not both.

#2 Updated by Giovanni Manghi almost 5 years ago

Jürgen Fischer wrote:

You might be mixing repositories. You should either have qgis.org/debian-ltr or qgis.org/ubuntugis-ltr, but not both.

Hi Jürgen,
I don't have mixed repos but I also have problems installing the plugin on Ubuntu 14.04.

I use qgis.org/ubuntugis-ltr and at the moment it installs qgis 2.8.5 (1:2.8.5+20trusty-ubuntugis), but the package

qgis-plugin-grass(-common)

is "1:2.8.3+20trusty-ubuntugis" and not installable.

There is a

qgis-provider-grass

package (1:2.8.5+20trusty-ubuntugis) that is installed, but no GRASS plugin.

#3 Updated by Jürgen Fischer almost 5 years ago

Right. For distributions with GRASS7 there is no grass plugin in 2.8. GRASS7 support in plugin was added in 2.12 - only the grass provider (including browsers support) is available with GRASS7 in 2.8.

#4 Updated by Richard Carpenter almost 5 years ago

Jürgen,

I've tried installing it using 'debian-ltr' and 'ubuntugis-ltr', but not at the same time. I comment out the line of the repository I don't want with '##' in the /etc/apt/sources.list file.

If I am interpreting your reply to Giovanni correctly, are you saying that the 'qgis-plugin-grass' is not necessary/available for QGIS 2.8.X?

I am new to using GIS software, and have a project where I'll be required to use it, so I want to make sure I have everything in order prior to starting it.

Thank you for your help!

R/S,
Rich

#5 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Richard Carpenter wrote:

Jürgen,

I've tried installing it using 'debian-ltr' and 'ubuntugis-ltr', but not at the same time. I comment out the line of the repository I don't want with '##' in the /etc/apt/sources.list file.

If I am interpreting your reply to Giovanni correctly, are you saying that the 'qgis-plugin-grass' is not necessary/available for QGIS 2.8.X?

yes, it is not available for QGIS 2.8.x. But... if GRASS is installed in your system (6.4 or 7) then you can use its tools within the Processing toolbox (that supports both GRASS versions).

I am new to using GIS software, and have a project where I'll be required to use it, so I want to make sure I have everything in order prior to starting it.

if you really need the GRASS plugin (so to allow you to work with data that is stored in the GRASS data model) then install QGIS 2.12.x instead of 2.8.x by using the http://qgis.org/ubuntugis repo instead http://qgis.org/ubuntugis-ltr (plus the ubuntugis one of course).

Also available in: Atom PDF