Bug report #13948

PyQGIS doesn't work

Added by dr - over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:Matthias Kuhn
Category:Python plugins
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21963

Description

>>> import qgis
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "qgis/__init__.py", line 36, in <module>
    from qgis.core import QgsFeature, QgsGeometry
  File "qgis/core/__init__.py", line 10, in <module>
    from PyQt.QtCore import QCoreApplication
ImportError: No module named PyQt.QtCore

Associated revisions

Revision 197ee6cb
Added by Matthias Kuhn over 4 years ago

Fallback to pure PyQt4 for the moment

Fix #13948

Will probably require some packaging adjustments when reintroducing this.

History

#1 Updated by dr - over 4 years ago

But this import works fine:

from PyQt4.QtCore import QCoreApplication

#2 Updated by dr - over 4 years ago

  • Assignee set to Matthias Kuhn

It looks like this issue came after this 9ff6e1d

#3 Updated by Matthias Kuhn over 4 years ago

  • Status changed from Open to Feedback

Do you run "make install"?
Can you run from the build directory?

#4 Updated by dr - over 4 years ago

Matthias Kuhn wrote:

Do you run "make install"?
Can you run from the build directory?

I'm using QGIS from package (http://qgis.org/ubuntugis-nightly repository), not built it manually.

#5 Updated by Anonymous over 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF