Bug report #13886

Applying qml old style make legend height crazy and then crash QGIS

Added by Thomas Gratier over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.12.0 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21908

Description

My environnement:

Linux Ubuntu 14.04 64 bits with QGIS 2.12

How to reproduce (if not due to my platform)?

Download QML file from https://raw.githubusercontent.com/charleyglynn/OSM-Shapefile-QGIS-stylesheets/master/QML%20files/roads.qml
Then, go to Geofabrik to get SHP files from http://download.geofabrik.de/europe/france/champagne-ardenne-latest.shp.zip
Create a new project and add the downloaded layer roads.shp file.
Apply the QML style roads.qml to roads.shp layer

screenshot-error.png (334 KB) Thomas Gratier, 2015-11-26 03:02 PM

History

#1 Updated by Thomas Gratier over 4 years ago

It affects the layer tree and then the rendering: never stop refreshing the canvas

#2 Updated by Thomas Gratier over 4 years ago

It seems to be due to the units for styling (my default project was using EPSG 4326, hence degrees) and my styles depends from map units. So, my width for lines was 3 or 4 degrees sometimes.

Anyway, this behaviour should raise an error or a warning to say "Your width is too large considering the units configuration, you should change it" instead of the error that lead to "dumb" memory consumption.

#3 Updated by Thomas Gratier over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF