Bug report #13866

Copy Paste attribute table from postgres causes crash

Added by Regis Haubourg over 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:High
Assignee:Sandro Santilli
Category:Attribute table
Affected QGIS version:2.12.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21889

Description

Hi,
copying / pasting from attribute table to the same attribute table, data from postgres, causes systematic crash in 2.12.

Table is non geometric.

History

#1 Updated by Regis Haubourg over 4 years ago

Worse than this, it is not possible at all to copy lines from attribute table, from menu. It is greyed out there, when copy paste buttons from attribute table are enabled

#2 Updated by Sandro Santilli about 4 years ago

  • Assignee set to Sandro Santilli
  • Status changed from Open to In Progress

#3 Updated by Sandro Santilli about 4 years ago

  • Status changed from In Progress to Feedback

I cannot reproduce with current master (670ded3)
Maybe it was a threading issue fixed recently. Could you please re-try ?

#4 Updated by Regis Haubourg about 4 years ago

  • Status changed from Feedback to Closed

Confirmed! Thanks Sandro, it seems solved.
Cheers
Régis

Also available in: Atom PDF