Bug report #13849

Selfcompiled QGIS 2.12 segfaults on startup on Ubuntu 14.04

Added by Stefan Blumentrath about 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:2.12.0 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21873

Description

After compiling QGIS 2.12 release branch from source on Ubuntu 14.04, QGIS segfaults at startup.
Others seem to be hit by the same issue too, see:
https://lists.osgeo.org/pipermail/qgis-user/2015-October/034109.html

History

#1 Updated by Stefan Blumentrath about 4 years ago

Tried also 2.10, which gives the same behavior.

Master did not build:
Compiling /data/src/QGIS_dev/qgis-dev/output/python/PyQt/QtPrintSupport.py ...
File "/data/src/QGIS_dev/qgis-dev/output/python/PyQt/QtPrintSupport.py", line 3
QPageSetupDialog
^
SyntaxError: invalid syntax

Maybe an Ubuntu issue, since non of the tested branches build?

#2 Updated by Stefan Blumentrath almost 4 years ago

  • Status changed from Open to Closed

This was an issue of the Linux kernel shipped with Ubuntu 14.04 LTS at the time of issue creation. After kernel update (and rebuild) QGIS works again...

Also available in: Atom PDF