Bug report #13842

QGIS 2.12 crash on opening layer properties

Added by Lewis Hein almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:2.12.0 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:21866

Description

Qgis 2.12 crashes when opening the layer properties dialog using this configuration file.
This file works fine in qgis 2.10, and the problem appeared after upgrading to 2.12.

To reproduce the problem:
1 Place the attached file in $HOME/.config/QGIS/QGIS2.conf
2 Open QGIS 2.12 and create a new project.
3 Add a new vector layer with the default settings.
4 Open the layer properties dialog (Layer->Properties)

QGIS will freeze and then segfault.

Output and backtrace from LLDB version 3.6 is also attached

lldb-3.6_output.txt Magnifier - Output and backtrace from LLDB version 3.6 (11.4 KB) Lewis Hein, 2015-11-16 03:47 PM

QGIS2.conf Magnifier - Configuration file (49.4 KB) Lewis Hein, 2015-11-16 03:47 PM

History

#1 Updated by Sandro Santilli almost 5 years ago

  • Status changed from Open to Feedback

I cannot reproduce with current master (2.14-pre -- 69cb0c4ed3174946c82e32dad4af5a12275079fc)
Can you ?

#2 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback. Please reopen if necessary.

Also available in: Atom PDF