Bug report #13826

Selecting features hangs QGIS 2.12.0 on OS X

Added by Michal Jurewicz about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Canvas
Affected QGIS version:2.12.0 Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21851

Description

I found problem with newest QGIS 2.12.0 on OS X 10.11.1. Selecting any features hangs QGIS. First few selection works fine but after a few any next selecting/deselecting takes more and more time and finally hangs QGIS completely. For now it make QGIS totally worthless for editing vector data.

BTW I'm working on SHP files with EPSG:4326 projection and UTF-8 encoding.

Sample_data.zip (10.3 KB) Michal Jurewicz, 2015-11-13 06:12 AM

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback

did it happen in previous qgis releases? can you attach sample data?

#2 Updated by Giovanni Manghi about 5 years ago

  • Category set to Map Canvas

#3 Updated by Michal Jurewicz about 5 years ago

I send you some sample data. By the way it is EPSG:2180 not 4326.
At this moment I noticed one more thing, it happens only when selecting features on layer which is in edition mode. When layer is not editable selecting works fine.

And on versions 2.8 and 2.10 selection features worked fine.

#4 Updated by Giovanni Manghi about 5 years ago

cannot replicate on qgis master/linux. Can you test on other platforms?

#5 Updated by Giovanni Manghi about 5 years ago

forgot: this can be very well be caused by a 3rd party plugin. Please try without any plugin active.

#6 Updated by Michal Jurewicz about 5 years ago

  • Status changed from Feedback to Closed

It was good idea to check plugins. At first a disabled all plugins (3rd party and genuine ones) and problem disappeared. So I made enable all plugins back and problem didn't come back. Some plugin needed reactivation.

BTW when problem occurred it looked like this: http://quick.as/pQ2audPbk

Thanks for helping me!

#7 Updated by Michal Jurewicz about 5 years ago

My happiness was to early, problem occurred one more time. However this time I target which plugin makes problem and it is Digitizing Tools.

#8 Updated by Steve Lowman almost 5 years ago

I agree. It is since the last upgrade to the Digitizing Tools plugin.
We are working with shapefiles in QGIS 2.8.2. The hanging and crashing happens as already described. I thought it was happening quicker after some edits like splitting and merging of features, but yes it hangs when you click a feature to select, and the hanging gets progressively longer in duration until it just hangs and does not come back.
We are currently keeping the plugin disabled, and just enabling it temporarily when we need to use a tool, then disabling again.

Also available in: Atom PDF