Bug report #13821

Qgis not deleting polygons

Added by Dan Isaacs about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.12.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21846

Description

I have a shapefile in which I deleted some polygons and added some new ones. The changes were saved, the project containing that layer re-opened some text data added and the layer saved again.
If this shapefile is opened in any other software (I've tried MapMaker and ArcGis) the polygons that I deleted are still there. In fact if you open the .dbf file in Excel, all the data for the deleted polygons is still there. Interestingly, if you open the .dbf files in a database editor (I use OpenOffice Base), the deleted polygons do not appear.
Of further interest if one makes any changes directly to the .dbf file in OpenOffice Calc, the new polygons are deleted and the layer seems to revert to the old ones.
I've opened the shapefile in a new project to check it's not the project settings that are corrupted, but the same happens.

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #11007

Also available in: Atom PDF