Bug report #13818

Selecting multiple files in SAGA/Processing uses wrong separator

Added by Guillaume Larocque almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/SAGA
Affected QGIS version:2.12.0 Regression?:No
Operating System:Linux/Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21843

Description

"Processing>SAGA>Cluster Analysis for Grids" does not work when selecting more than one grid files. The attached error log indicates that the problem is with the import from the tif files. The command seems to use commas as separators between file paths. Executing that command with saga_cmd also fails, but replacing the commas with semi-colons fixes it.

This is under Linux/Ubuntu. I haven't tested to see if it is also a problem on other platforms.

saga_err.txt Magnifier (952 Bytes) Guillaume Larocque, 2015-11-12 10:59 AM

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Feedback

What Processing version are you using?

#2 Updated by Guillaume Larocque almost 5 years ago

This is under QGIS 2.12.0. I'm using the version of Processing that comes with it...

#3 Updated by Giovanni Manghi almost 5 years ago

Guillaume Larocque wrote:

This is under QGIS 2.12.0. I'm using the version of Processing that comes with it...

do you have any "processing" folder inside .qgis2/python/plugins/ ?

#4 Updated by Victor Olaya almost 5 years ago

semicolons are already used, see here

https://github.com/qgis/QGIS/blob/master/python/plugins/processing/algs/saga/SagaAlgorithm213.py#L105

Looks like yo uare using an older version (or an older version in your system is shadowing the one that comes with QGIS 2.12)

#5 Updated by Giovanni Manghi almost 5 years ago

Victor Olaya wrote:

(or an older version in your system is shadowing the one that comes with QGIS 2.12)

yes, that's my guess.

#6 Updated by Guillaume Larocque almost 5 years ago

How does one re-install processing to make sure I have the newer version?

#7 Updated by Giovanni Manghi almost 5 years ago

Guillaume Larocque wrote:

How does one re-install processing to make sure I have the newer version?

remove any "processing" folder inside .qgis2/python/plugins/

restart qgis, update Processing if a new version is available in the plugin manager.

#8 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

closing for lack of feedback.

Also available in: Atom PDF