Bug report #13791

on QGIS master Processing results from GDAL/OGR tools are no longer added to map

Added by Giovanni Manghi about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/GDAL
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21817

Description

The tools run but all return the

The following layers were not correctly generated.

message.

The outputs are actually created on disk.

Associated revisions

Revision 7e793986
Added by Victor Olaya about 4 years ago

[processing] fixed adding raster layer to project
fixes #13791

History

#1 Updated by Victor Olaya about 4 years ago

  • Status changed from Open to Closed

#2 Updated by Giovanni Manghi about 4 years ago

Hi Victor, I tested your latest commits and it seems that it still does not work (for me at least). Cheers!

#3 Updated by Victor Olaya about 4 years ago

Hey Giovanni. I am not able to reproduce it. It works fine when using GDAL and OGR algorithms with raster and vector layers.

I have added some code to add detailed error descriptions to the log when the postprocessing task fails. Can you please download the latest code, run the algorithm that is failing and paste here the error trace that you will see in the log?

Thanks!

#4 Updated by Giovanni Manghi about 4 years ago

Victor Olaya wrote:

Hey Giovanni. I am not able to reproduce it. It works fine when using GDAL and OGR algorithms with raster and vector layers.

I have added some code to add detailed error descriptions to the log when the postprocessing task fails. Can you please download the latest code, run the algorithm that is failing and paste here the error trace that you will see in the log?

Thanks!

Just updated to the latest master and it seems fixed, Thanks!

Also available in: Atom PDF