Bug report #13783

Compiling QGIS with Oracle libs does not let you install as non-root user

Added by Richard Duivenvoorde over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/Oracle
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:21809

Description

If you compile QGIS with Oracle driver and wants to install QGIS as non-root user the 'make install' fails because make tries to install the libqsqlocispatial.so in the system libs dir.

Not sure if this is by accident, or is a nessecity:

-- Up-to-date: /usr/lib/x86_64-linux-gnu/qt4/plugins/sqldrivers/libqsqlocispatial.so
CMake Error at src/providers/oracle/ocispatial/cmake_install.cmake:50 (file):
  file INSTALL cannot set permissions on
  "/usr/lib/x86_64-linux-gnu/qt4/plugins/sqldrivers/libqsqlocispatial.so" 
Call Stack (most recent call first):
  src/providers/oracle/cmake_install.cmake:55 (include)
  src/providers/cmake_install.cmake:48 (include)
  src/cmake_install.cmake:42 (include)
  cmake_install.cmake:56 (include)

Makefile:93: recipe for target 'install' failed
make: *** [install] Error 1

History

#1 Updated by Jürgen Fischer over 4 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

The sqldrivers (ocispatial but also qspatialite) are installed into the default directory for Qt plugins (QT_PLUGINS_DIR) - otherwise Qt won't find them by default.

Also available in: Atom PDF