Bug report #13711

[compile] qgis master build fails at qgspythonutilsimpl.cpp:388:58 with ‘PyUnicode_AsUTF8’ error

Added by Donovan Cameron almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21738

Description

I'm getting a "error: ‘PyUnicode_AsUTF8’ was not declared in this scope" when building QGIS Master.

[ 91%] Building CXX object src/python/CMakeFiles/qgispython.dir/qgspythonutilsimpl.cpp.o
/tmp/makepkg/qgis-git/src/qgis/src/python/qgspythonutilsimpl.cpp: In member function ‘QString QgsPythonUtilsImpl::getTraceback()’
/tmp/makepkg/qgis-git/src/qgis/src/python/qgspythonutilsimpl.cpp:388:58: error: ‘PyUnicode_AsUTF8’ was not declared in this scope
result = QString::fromUtf8( PyUnicode_AsUTF8( obResult ) );
^
src/python/CMakeFiles/qgispython.dir/build.make:86: recipe for target 'src/python/CMakeFiles/qgispython.dir/qgspythonutilsimpl.cpp.o' failed
make[2]: *** [src/python/CMakeFiles/qgispython.dir/qgspythonutilsimpl.cpp.o] Error 1
CMakeFiles/Makefile2:3658: recipe for target 'src/python/CMakeFiles/qgispython.dir/all' failed
make[1]: *** [src/python/CMakeFiles/qgispython.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2

This is on Linux 64-bit.


Related issues

Duplicates QGIS Application - Bug report #13686: [compile] qgis master fails with "error: ‘PyUnicode_AsUTF... Closed 2015-10-27

History

#1 Updated by Donovan Cameron almost 5 years ago

  • Status changed from Open to Closed

Sorry. My memory is slipping and looks like I already reported this as #13686

Closing as duplicate.

Also available in: Atom PDF