Bug report #13689

Mouse behaviour in digitizing mode.

Added by Steven Veen about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.8.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:21719

Description

In digitizing mode QGIS sets his nodes at the place where I've released the mouse button (button up) instead of the place where I've clicked the button down (mouse down). As a result of this strange behaviour most of my nodes are a few pixels displaced. Is this a bug, or an illogical behavior?

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

I think this is by design. I see your point (but of course this do not seems to be an issue for the vast majority of the users) but anyway is better to discuss this in the developers and/or users mailing list.

Also available in: Atom PDF