Bug report #13656

LIKE is not case sensitive when Query Builder is accessed from Layer > shapefile > Filter... (QGIS, v10, Windows7)

Added by Michael Shin almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.10.0 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21691

Description

When using the Query Builder accessed via 'LAYER > right/CTRL-click SHAPEFILE layer > FILTER...' with wildcards (i.e, %) the operator LIKE (case-sensitive) performs identically to ILIKE (NOT case sensitive).

For example, consider a field called NAME that contains the following ('California', 'New Mexico', 'Michigan').

When accessed via Filter..., the query: "NAME LIKE '%c%' returns all three of the above, but the same query performed via 'Select by Expression' and 'Advanced Filter' returns (correctly, I think) only 'New Mexico' and 'Michigan'. This behavior has been replicated on different shapefiles.


Related issues

Duplicates QGIS Application - Bug report #6690: builder query gives wrong results with shapes (OGR bug?) Closed 2012-11-14

History

#1 Updated by Jürgen Fischer almost 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #6690

Also available in: Atom PDF