Bug report #13655

Bad metadata in the debian repository

Added by Lars Luthman almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Build/Install
Affected QGIS version:2.10.1 Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21690

Description

The file http://qgis.org/debian/dists/stable/Release contains the line

Suite: testing

even though it is in the 'stable' directory, and it also has the line

Codename: jessie

where 'jessie' has been 'stable' since April. The packages associated with this dist all seem to have been built for stable/Jessie rather than testing/Stretch, so I assume that it's only the Suite line that is incorrect.

This causes problems when you try to add the QGIS repository on a Debian stable/Jessie system, since you can't actually install any of the packages from the repository without telling apt-get to allow 'testing' packages.

Similarly, http://qgis.org/debian/dists/oldstable/Release has the line

Suite: stable

which should probable be oldstable instead.

The same thing seems to have happened after the Debian Wheezy release 2 years ago (#8649)

History

#1 Updated by Jürgen Fischer almost 5 years ago

  • Assignee set to Jürgen Fischer

#2 Updated by Jürgen Fischer almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF