Bug report #13620

Cancelling Layer Properties Dialog does not cancel changes made in "Provider feature filter" section

Added by Harrissou Santanna almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21658

Description

Open a layer Properties > General tab
write a formule in the Query builder and click "Test"
The query instead of just being tested, is also applied in the map canvas. I'm not sure if this behaviour is good but why not, since it shows how layer will be.
Now Click "OK" in the query builder dialog and click "CANCEL" in the Properties Dialog : your layer will be kept queried, despite you cancelled the process.

Shouldn't all the not yet applied changes, made within the Layer Properties dialog, be reversed when user hits Cancel button?

Occured since QGIS 2.4 at least

Associated revisions

Revision 53998555
Added by Sebastian Dietrich almost 5 years ago

restore original subset string on dialog cancel (fix #13620)

History

#1 Updated by Sebastian Dietrich almost 5 years ago

Please see PR 2480 for a fix.

#2 Updated by Anonymous almost 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF