Bug report #13571

data defined size assistant displays different size in legend vs canvas

Added by Regis Haubourg almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Vincent Mora
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21613

Description

Hi,
size assistant used for points generates legend size different from map size.
Correct size seems to be the one in the legend

size_assistant_issue.png (72.4 KB) Regis Haubourg, 2015-10-12 02:47 AM

issue13571.png (55.5 KB) Vincent Mora, 2015-11-09 12:48 AM

Associated revisions

Revision 701d9708
Added by Vincent Mora almost 5 years ago

fix wrong scale method with constant expressions
fix #13571

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Target version deleted (Version 2.12)

#2 Updated by Vincent Mora almost 5 years ago

Hi Regis, can you plz provide more details on how to reproduce. I attached the result of my attempt, and everything looks fine.

#3 Updated by Regis Haubourg almost 5 years ago

Hi,
easy in fact:

- test a point layer with a fixed symbol size to 24 for instance
- then replace size by an expression set to a constant of 24.

you have a far smaller icon with expression. I guess we have the old scaling area method still applying to any expression output

#4 Updated by Vincent Mora almost 5 years ago

  • Pull Request or Patch supplied changed from No to Yes

#5 Updated by Vincent Mora almost 5 years ago

  • Status changed from Open to Closed

#6 Updated by Regis Haubourg almost 5 years ago

Hi, I would be very thanksfull if a backport to 2.12 could be done. (christmas is coming...)
We financed this since 2.8 and that feature is ruined without this fix..

Also available in: Atom PDF