Bug report #13566

on-the-fly projection errors after changing symbology

Added by Flo Ju almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Projection Support
Affected QGIS version:2.8.3 Regression?:No
Operating System:Fedora Linux 22 KDE Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21608

Description

Having opened vector-layers (SHP) in different SRS (EPSG 31254 and 4258) and using on-the-fly transformation the position of transformed objects is wrong after changing symbology, tooggle visibility. It also occurs when using the layer from PostGIS. See attached screen-record.

out.ogv (2.8 MB) Flo Ju, 2015-10-11 08:40 AM

geodata1.tar.gz (2.93 MB) Flo Ju, 2015-10-11 11:26 AM

geodata2.tar.gz (3.3 MB) Flo Ju, 2015-10-11 11:26 AM

geodata3.tar.gz (3.3 MB) Flo Ju, 2015-10-11 11:26 AM

History

#1 Updated by Anita Graser almost 5 years ago

Please share some data to reproduce the issue. Can you also have a look if you have the same problem with the current development version?

#2 Updated by Flo Ju almost 5 years ago

Update with some of the sample data.
Project SRS was defined as ETRS89 (epsg 4258) with AT_GIS_GRID (NTv2-Transformation) manually integrated like described here: [[http://isticktoit.net/?p=371]].

Tomorrow I will have a look if I can reproduce this behaviour in QGIS 2.8.3/Windows and QGIS 2.10.

Thx from Austria

#3 Updated by Jürgen Fischer almost 5 years ago

  • Category set to Projection Support

#4 Updated by Anita Graser almost 5 years ago

Can you confirm that this only happens if the NTv2 transformation is configured?

I tried without and couldn't reproduce the issue.

#5 Updated by Flo Ju almost 5 years ago

Hi!
Little Update: Tested it with QGIS 2.10.1 (Windows), with NTv2 for Austria manually configured. Everything went fine and I was not able to reproduce it in this environment. Will do some tests on the 2.8 LTS/Fedora KDE Plasma 5 today or tomorrow again.

#6 Updated by Flo Ju almost 5 years ago

  • Status changed from Open to Closed

Good news: I have tested it in different environments (2.8 & 2.10 Win, 2.8.3 Linux/Ubuntu) and the problem just occurs in the mentioned F22/KDE environment and only if WMTS-Layers are involved in the project. In the other mentioned environments everything works fine. I close the issue because it seems very specific to the F22/KDE-System.

Also available in: Atom PDF