Bug report #13510

qt5: most keyboard shortcuts of a composer window not working

Added by Mathieu Pellerin - nIRV almost 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21554

Description

When compiling QGIS using Qt5 libraries, keyboard shortcuts - such as DEL, Ctrl+C, Ctrl+V, etc. - are not working for composer windows.

Steps to reproduce:
  1. Launch QGIS (compiled using Qt5 libraries)
  2. Create a new composer, and add a text item
  3. Select that text item, and try to paste a copy of it by hitting Ctrl+C and Ctrl+V
  4. Notice the copying / pasting doesn't work
  5. Now try to delete the item by hitting the DEL keyboard key
  6. Notice the deletion doesn't occur
  7. Now try to delete the item by hitting the BACKSPACE keyboard key
  8. Notice that actually works :)

This is obviously nothing very urgent to look into, but thought I'd file this as a reminder whenever QGIS will start moving to Qt5.

History

#1 Updated by Matthias Kuhn almost 4 years ago

  • Operating System set to Ubuntu

Works for me on Fedora.

#2 Updated by Mathieu Pellerin - nIRV over 3 years ago

I've just compiled QGIS under forthcoming Ubuntu LTS 16.04 to test whether the issue is still present under Qt5.5.

It is :) it would be nice to get rid of this issue prior to 2.16.

#3 Updated by Mathieu Pellerin - nIRV about 3 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Just compiled QGIS with Qt5.6, and the keyboard shortcut issue is gone. This is an issue with the upstream qt library, close this ticket.

Also available in: Atom PDF