Bug report #13488

Wrong overwriting behaviour with GRASS algorithms

Added by Christophe Bayle almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GRASS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21533

Description

I tried to use v.clean via the GUI in QGIS 2.10 on a polyline shapefile.
I selected an existing .shp as Cleaned layer target and got the warning 'the file already exists, do you want to delete ?' What i understand as 'do you want to over write it ?
Clic "Yes"
Uncheck the box "Open the file after executing ..."
Launch the process, everything seems to go as it should

But when i check my file it hasn't been overwrited.

Regards,

C.

History

#1 Updated by Saber Razmjooei almost 5 years ago

  • Affected QGIS version changed from 2.10.1 to master
  • Category changed from GRASS to Processing/GRASS
  • Target version deleted (Version 2.10)

I can confirm that the overwritting does not work indeed. For me in master, it comes up with an error indicating the output file was not correctly produced.

#2 Updated by Médéric RIBREUX over 4 years ago

  • Operating System deleted (Winows)
  • OS version deleted (7)
  • Status changed from Open to In Progress
  • Subject changed from Wrong overwriting behaviour with v.clean to Wrong overwriting behaviour with GRASS algorithms

Hello, bug triage...

I've made some tests on your bug and I can confirm that the problem is not related to v.clean only.
If you try to overwrite an already existing file with any GRASS Processing algorithm, there will be no overwrite.

I have made a PR to add the required parameter (--overwrite) to v.out.ogr and r.out.gdal commands.

#3 Updated by Médéric RIBREUX over 4 years ago

  • Estimated time set to 2.00
  • Status changed from In Progress to Closed
  • Resolution set to fixed/implemented
  • % Done changed from 0 to 100

Hello,

the PR is merged, it will be fixed in QGIS 2.14.

I am closing this bug !

Also available in: Atom PDF