Bug report #13472

Qgis crashes if in "options/canvas&legend" I turn on "create raster icons"

Added by Piotr Kania about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21519

Description

Hi!

I'm on win 7sp1 x64, osgeo4w x64, qgis dev a7cd198 - when option "create raster icon" is active, qgis crashes and creates crash dump, if I try to open project with rasters. If I turn off "create raster icon" in options, I can than open that project. It didn't happen with previous qgis-dev fea4ed9.

History

#1 Updated by Saber Razmjooei about 5 years ago

  • Status changed from Open to Feedback

Can't reproduce. Could you provide example data/project?

#3 Updated by Saber Razmjooei almost 5 years ago

Thanks for the files.

This is likely to be due to another problem. I have loaded "only" the rasters and saved it as a new project and it works fine.

Could you try the followings:
- try to rename .qgis2 folder (so with no plugins)
- disable multi-threaded rendering

#4 Updated by Piotr Kania almost 5 years ago

Saber Razmjooei wrote:

Thanks for the files.

This is likely to be due to another problem. I have loaded "only" the rasters and saved it as a new project and it works fine.

Could you try the followings:
- try to rename .qgis2 folder (so with no plugins)
- disable multi-threaded rendering

I tried with that options, but qgis dev stills crashes when I open the project

#5 Updated by Saber Razmjooei almost 5 years ago

It is not possible to replicate the problem with the raster file only.

Could you confirm that is the case when you only have the attached raster in your QGIS session and no other layer?

#6 Updated by Piotr Kania almost 5 years ago

  • Status changed from Feedback to Closed

If I use just a few raster layers - everything is ok, but qgis crashes if I try to open my project with a lot of layers

Also available in: Atom PDF