Bug report #13428

PyQt not aware of qgis_customwidgets.py

Added by Lauri Kajan almost 5 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:Denis Rouzaud
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:windows / osgeo4w Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21475

Description

On osgeo4w installation compiling ui files with pyuic4 produces wrong imports for qgis custom widgets.
Also all the plugins are affected that try to use ui-files directly with uic.loadUiType(). Plugins crash in this situation.

This is because of PyQt is not aware of qgis_customwidgets.py located in qgis\\python\\PyQt4\\uic\\widget-plugins folder.
In the qgis_customwidgets.py it is commented that the file should be copied into /pythonX/dist-packages/PyQt4/uic/widget-plugins/ but it is not.

This is discussed in https://lists.osgeo.org/pipermail/qgis-developer/2015-September/039196.html

History

#1 Updated by Denis Rouzaud almost 5 years ago

  • Assignee set to Denis Rouzaud

discussing it with Jürgen.

#2 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Denis Rouzaud about 2 years ago

  • Status changed from Open to Closed
  • Description updated (diff)

it should be fixed

Also available in: Atom PDF