Bug report #13422

deleted feature within shapefile are not really deleted and count is false

Added by Alain FERRATON about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/OGR
Affected QGIS version:2.10.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21471

Description

do the following :
- open test.shp
- show feature count > 5
toogle edition
- delete all feature, count = 0
- save -> count return to 5, attribute table is ok (row = 0).

even close and reopening count = 5 and the file size has not changed.

see also #11007

test.zip (1.85 KB) Alain FERRATON, 2015-09-25 02:31 AM


Related issues

Related to QGIS Application - Bug report #13297: Edited/Deleted features still in Shapefile Closed 2015-08-31
Related to QGIS Application - Bug report #11007: Deleted/edited features within SHAPEFILE are still recogn... Closed 2014-08-05

History

#1 Updated by Saber Razmjooei about 4 years ago

  • Resolution set to duplicate
  • Target version set to Version 2.12
  • Status changed from Open to Closed

I am re-opening the original ticket.

#2 Updated by Karl Kastner about 4 years ago

  • Status changed from Closed to Reopened

I can confirm this on QGIS 2.8.1 "Wien" (Ubuntu 15.4). This issue is not resolved when calling repack / assigning new IDs and does not need SAGA raster processing to be reproduced. Does any one know a work around?

#3 Updated by Saber Razmjooei about 4 years ago

  • Status changed from Reopened to Closed

The work-around is to save the file as a new file.

Please add your comments to the original ticket #11007

Thanks,

Also available in: Atom PDF