Bug report #13396

Node tool's errors

Added by Piotr Kania about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:21448

Description

Hi!
I'm on win 7sp1 x64, OSGeo4W64 - qgis-dev-2.11.0-72. In some situations when I use "Node tool" and try to move selected vertex it just add new vertex, you can see what I mean on film:

https://www.dropbox.com/s/6tiwedihce3teoc/clip.mp4?dl=0

It didn't happen in qgis-dev-2.11.0-63, all later versions work in that bad way

History

#1 Updated by Piotr Kania about 5 years ago

mp4 video file has good resolution - it's better to download it and watch on computer than through dropbox player

#2 Updated by Piotr Kania about 5 years ago

  • Status changed from Open to Closed

Thanks - in qgis-dev-2.11.0-73 works,

thanks for your work

#3 Updated by Piotr Kania about 5 years ago

  • Status changed from Closed to Reopened

Hi - in qgis-dev-2.11.0-73 everything is ok if I edit linestring layer, problem still exists during editing multipolygon layer

#4 Updated by Jürgen Fischer about 5 years ago

Piotr Kania wrote:

Hi - in qgis-dev-2.11.0-73 everything is ok if I edit linestring layer, problem still exists during editing multipolygon layer

BTW please quote the git SHA (as shown in the window title and as code version in the about box in master/qgis-dev) instead of the package version (ie. 16d7a06 instead of 2.11.0-73). 73 is just a running number of the osgeo4w packages. Those don't have a obvious relation to commits and might not even be the same between 32bit and 64bit osgeo4w builds of the same state/commit of master.

#5 Updated by Piotr Kania about 5 years ago

Sorry - I didn't know that, the last qgis version 2.11.0-Master in which "Node tool" works great is - QGIS code revision - f3c7d85, it was released 11 sept. 2015, all versions later have worse "working mode" of "Node tool"

#6 Updated by Saber Razmjooei about 5 years ago

  • Status changed from Reopened to Feedback

Works fine in 935dca0 for me.

#7 Updated by Saber Razmjooei about 5 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Closed due to lack of response. All works fine for me.

Also available in: Atom PDF