Bug report #13381

dxf file minidump

Added by salvatore fiandaca almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.10.1 Regression?:No
Operating System:all Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:21433

Description

software/hardware:
QGIS 2.10 standalone 64 bit, Windows 10 64 bit / Lenovo Z50 75 FX amd - 8 GB RAM

problem: dxf file minidump
fast minidump procedure:
1.Create a new qgis project, import a dxf file, create a group collect all entities together, save your project (attached);
2.shut down qgis, then te-star it and select point 1 project from 'layer → incude layer and groups' , include group displayed;
3.the group will now appear in the TOC, but nothing will show in the map canvas;
4.Zoom on group to show the minidump window.

minidump_dxf.7z (11.3 KB) salvatore fiandaca, 2015-09-19 02:22 PM

History

#1 Updated by Sandro Santilli almost 4 years ago

Can be reproduced under linux with current master.
Point 2 is "Layers -> Embed layers and groups"

Stacktrace:

Program received signal SIGSEGV, Segmentation fault.  
0x00007ffff378929c in QgsLayerTreeViewDefaultActions::zoomToLayers (this=0x17b8de0, canvas=0x1374f10, layers=...)
    at /usr/src/qgis/qgis-master/src/gui/layertree/qgslayertreeviewdefaultactions.cpp:204
warning: Source file is more recent than executable.  
204       QgsMapCanvas* canvas = reinterpret_cast<QgsMapCanvas*>( s->data().value<void*>() );
(gdb)
(gdb)
(gdb) bt
#0  0x00007ffff378929c in QgsLayerTreeViewDefaultActions::zoomToLayers (this=0x17b8de0, canvas=0x1374f10, layers=...)
    at /usr/src/qgis/qgis-master/src/gui/layertree/qgslayertreeviewdefaultactions.cpp:204
#1  0x00007ffff37890a0 in QgsLayerTreeViewDefaultActions::zoomToGroup (this=0x17b8de0, canvas=0x1374f10)
    at /usr/src/qgis/qgis-master/src/gui/layertree/qgslayertreeviewdefaultactions.cpp:178
#2  0x00007ffff37891f3 in QgsLayerTreeViewDefaultActions::zoomToGroup (this=0x17b8de0)
    at /usr/src/qgis/qgis-master/src/gui/layertree/qgslayertreeviewdefaultactions.cpp:192
#3  0x00007ffff390769c in QgsLayerTreeViewDefaultActions::qt_static_metacall (_o=0x17b8de0, _c=QMetaObject::InvokeMetaMethod, _id=6, 
    _a=0x7fffffffb040) at /usr/src/qgis/build/master/src/gui/layertree/moc_qgslayertreeviewdefaultactions.cxx:67
#4  0x00007ffff274487a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007ffff1ac3a62 in QAction::triggered(bool) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#6  0x00007ffff1ac5433 in QAction::activate(QAction::ActionEvent) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#7  0x00007ffff1ef3509 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#8  0x00007ffff1ef7a39 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#9  0x00007ffff1b1951a in QWidget::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#10 0x00007ffff1efb83b in QMenu::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#11 0x00007ffff1ac9e2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#12 0x00007ffff1ad05dd in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#13 0x00007ffff3f8f0b5 in QgsApplication::notify (this=0x7fffffffd520, receiver=0x39b1340, event=0x7fffffffb6e0)
    at /usr/src/qgis/qgis-master/src/core/qgsapplication.cpp:255
#14 0x00007ffff27304dd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#15 0x00007ffff1acfd93 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4

#2 Updated by Sandro Santilli almost 4 years ago

  • OS version deleted (Windows 10)
  • Tag changed from minidump to minidump, dxf, layergroups
  • Operating System changed from Windows 10 to all
  • Target version set to Version 2.12

#3 Updated by Sandro Santilli almost 4 years ago

Cannot reproduce with 22313dc, fixed ?
Salvatore can you try that ?

#4 Updated by Salvatore Larosa almost 4 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

I had issued a PR here [0] and Jurgen has pushed a more complete fix in 1fe34b3. The problem was not only with ogr provider.

So it is definitively fixed!

Also available in: Atom PDF