Bug report #13374

Crash on loading MySQL geometry Layer

Added by Marco Lechner almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/OGR
Affected QGIS version:2.10.1 Regression?:No
Operating System:Debian/Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21426

Description

While trying to connect to a MySQLDB serving geometries, QGIS crashes when loading the layer (POINT with only one entry).
Using 2.8.3 on Debian it crashes immediately when connecting even before it presents the list of available tables in the DB.
Using QGIS 2.10 on Ubuntu QGIS crashes when trying to load the layer. It successfully gets and presents the list of available Layers but when trying to load the POINT layer it crashes immediately after noticing that it could not get the layers SRS and therfore assuming WGS8 (which is correct in my testcase).
Crashes always generates a segfault-error without further information.

This bug does not seem to be necessarily an OGR issue, because using ogr2ogr on the machines succesfully imports a shp into MySQL and even successfully exports it from the DB back to a Shapefile without problems.

QGIS_crashlog.txt Magnifier - crash dump (2.22 KB) Marco Lechner, 2015-09-17 02:04 AM

QGIS_crashlog_2.10.txt Magnifier (2.22 KB) Marco Lechner, 2015-09-27 11:23 AM

History

#1 Updated by Marco Lechner almost 5 years ago

crash dump for 2.8.3 attached.

#2 Updated by Saber Razmjooei almost 5 years ago

  • Status changed from Open to Feedback

Could you set turn off the parallel rendering and try again?
It is under Settings > Options > Rendering > Render layers in parallel using many CPU cores (untick this option).

#3 Updated by Marco Lechner almost 5 years ago

Hi Saber,

with definitely unticked parallel rendering the error is the same (crashdump.log from available QGIS 2.10) attached. Anyway, I'm quite sure the parallel rendering was unticked when the first dump has been created as well.

Marco

#4 Updated by Saber Razmjooei almost 5 years ago

  • Status changed from Feedback to Open

#5 Updated by Martin Dobias almost 5 years ago

Most likely duplicate of #10622

What version of GDAL do you use?

#6 Updated by Marco Lechner almost 5 years ago

GDAL/OGR 1.10.1

will try a different version as soon as possible - have to install an Ubuntu Wily to get a QGIS compiled (or running?) against GDAL/OGR 1.11.1.
My Ubuntu trusty (14.04 + deb http://qgis.org/debian trusty main) uses 1.10.1 :-(

Marco

#7 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Feedback

#8 Updated by Marco Lechner over 4 years ago

  • Status changed from Feedback to Closed

seems to be fixed using GDAL 1.11.x as described in duplicate issue.
Tested to use a mysql-Connection using QGIS 2.12.x on Ubuntu 15.04/GDAL 1.11.2 and some openSuSE using a QGIS compiled against a GDAL 1.11.x

Anyway closing this ticket, even backporting a "fix" to QGIS LTR (2.8.x) means providing a QGIS 2.8.x-Version depending on an increased GDAL-Version.

Also available in: Atom PDF