Bug report #13369

crash on exit

Added by Salvatore Larosa about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Matthias Kuhn
Category:Map Tools
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21421

Description

With the latest master I am getting a crash when quitting the application

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff2c162e5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) ()
   from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
(gdb) bt
#0  0x00007ffff2c162e5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) ()
   from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#1  0x00007ffff4b3e34d in QgsMapLayer::repaintRequested (this=0x0)
    at /home/sam/pacchetti_gis/QGIS/build-master/src/core/moc_qgsmaplayer.cxx:180
#2  0x00007ffff4847c92 in QgsMapLayer::triggerRepaint (this=0x0) at /home/sam/pacchetti_gis/QGIS/src/core/qgsmaplayer.cpp:1594
#3  0x00007ffff3fc6c24 in QgsMapToolCapture::stopCapturing (this=0x15561b0)
    at /home/sam/pacchetti_gis/QGIS/src/gui/qgsmaptoolcapture.cpp:385
#4  0x00007ffff3fc5820 in QgsMapToolCapture::~QgsMapToolCapture (this=0x15561b0, __in_chrg=<optimized out>)
    at /home/sam/pacchetti_gis/QGIS/src/gui/qgsmaptoolcapture.cpp:69
#5  0x000000000069b289 in QgsMapToolAddFeature::~QgsMapToolAddFeature (this=0x15561b0, __in_chrg=<optimized out>)
    at /home/sam/pacchetti_gis/QGIS/src/app/qgsmaptooladdfeature.cpp:44
#6  0x000000000069b2bc in QgsMapToolAddFeature::~QgsMapToolAddFeature (this=0x15561b0, __in_chrg=<optimized out>)
    at /home/sam/pacchetti_gis/QGIS/src/app/qgsmaptooladdfeature.cpp:46
#7  0x00000000004e6c08 in QgisApp::~QgisApp (this=0x11462a0, __in_chrg=<optimized out>)
    at /home/sam/pacchetti_gis/QGIS/src/app/qgisapp.cpp:1005
#8  0x00000000004e76c0 in QgisApp::~QgisApp (this=0x11462a0, __in_chrg=<optimized out>)
    at /home/sam/pacchetti_gis/QGIS/src/app/qgisapp.cpp:1064
#9  0x00000000004dd870 in main (argc=1, argv=0x7fffffffe3f8) at /home/sam/pacchetti_gis/QGIS/src/app/main.cpp:1213

Associated revisions

Revision 0826290c
Added by Matthias Kuhn about 4 years ago

Fix crash on exit (Fix #13369)

History

#1 Updated by Salvatore Larosa about 4 years ago

  • Assignee set to Matthias Kuhn

#2 Updated by Matthias Kuhn about 4 years ago

  • Status changed from Open to Feedback

Hmmm... I cannot reproduce it.
Are you dealing with raster layers? Doing something fancy when exiting like leaving the add feature map tool in an unfinished state?

If you have a second to compile, can you patch src/gui/qgsmaptoolcapture.cpp and add a safety check at line 385:

if ( currentVectorLayer() )
currentVectorLayer()->triggerRepaint();

#3 Updated by Salvatore Larosa about 4 years ago

I just start QGIS and then quit it.

Your patch fixes the crash here. Thanks.

#4 Updated by Anonymous about 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF