Bug report #13302

long line in legend

Added by Denis Rouzaud about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:High
Assignee:Vincent Mora
Category:Map Legend
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21360

Description

Recently, I have a weird thing in a legend entry: the line smybol is way too large and I can't see the text if the dock is not large enough:

Associated revisions

Revision d7103dfb
Added by Vincent Mora about 4 years ago

fix varying line width when legend updates
fix #13302

History

#1 Updated by Denis Rouzaud about 4 years ago

this does not happen in the layer properties:

#2 Updated by Martin Dobias about 4 years ago

  • Assignee changed from Martin Dobias to Vincent Mora

#3 Updated by Vincent Mora about 4 years ago

Hi Denis,

I have tried to reproduce with today's master tests/testdata/lines.shp and failed (legend looks OK both in legend pannel and composer).

Can you provide a sample project please ?

#4 Updated by Vincent Mora about 4 years ago

  • Assignee changed from Vincent Mora to Denis Rouzaud

#5 Updated by Salvatore Larosa about 4 years ago

This is very easy to reproduce. I created a project with tests/testdata/lines.shp and you can watch what is happening in this video: http://lrssvt.ns0.it/img/13302.ogv

#6 Updated by Vincent Mora about 4 years ago

Ok, reproduced, it's on legend refresh that the size increases. I think I know where the problem is, will fix that asap.

Thanks for the video.

#7 Updated by Vincent Mora about 4 years ago

  • Assignee changed from Denis Rouzaud to Vincent Mora
  • Pull Request or Patch supplied changed from No to Yes

#8 Updated by Vincent Mora about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF