Bug report #13301

Load more than one shp file, making some not visible, and 'Identify Feature' will give info for shapes not visible

Added by Ray Kiddy almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21359

Description

This was confusing, but I think I see what is going on now.

I loaded 3 shp files. I downloaded:

ftp://ftp2.census.gov/geo/tiger/TIGER2015/UNSD/tl_2015_06_unsd.zip
ftp://ftp2.census.gov/geo/tiger/TIGER2015/SCSD/tl_2015_06_scsd.zip
ftp://ftp2.census.gov/geo/tiger/TIGER2015/ELSD/tl_2015_06_elsd.zip

I unzipped these and opened the shp files in them (using Layer -> 'Add Vector Layer...')

I have them displaying with different colors and flipped through the various layers.

What is wrong is this. If I check the ELSD layer but select the UNSD layer in the layer browser list, then when I use the 'Identify Feature' tool, it identifies the UNSD shapes even though I cannot see them. I am looking, in the map, at only the ELSD shapes.

See the screen shot enclosed. The shapes displayed are ELSD but the tl_2015_06_scsd layer has been selected in the layer browser and the selected area in the map and the 'Identify Results' info is for a SCSD.

If all I can see at the present moment are the ELSD shapes, then when I click on a shape, that is the shape that the tool should act on. Anything else seems non-obvious. The fact that the UNSD layer is selected in the browser should be irrelevant if the UNSD shapes are not being displayed.

In the second screen shot, it seems even clearer. The shape being described in the 'Filter Results' is not drawn on the map at all.

IdentifyFeatureWeirdness1.png (311 KB) Ray Kiddy, 2015-08-31 10:37 PM

IdentifyFeatureWeirdness2.png (328 KB) Ray Kiddy, 2015-08-31 10:37 PM

History

#1 Updated by Harrissou Santanna almost 5 years ago

Hi,
This is not a bug but might have to do with the mode you set for the Identify tool. reading this, you may have chosen "Current Layer" so features from the selected layer, visible or not, are identified. Try with "Top down" option.

#2 Updated by Saber Razmjooei almost 5 years ago

  • Status changed from Open to Feedback

#3 Updated by Ray Kiddy almost 5 years ago

The suggestion to switch the mode of the Identify tool to 'top down' gave me the expected behavior.

Perhaps this should be the default setting. Does the current default make more sense, perhaps in some other use case?

#4 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Feel free to make a suggestion/patch for the documentation.

Also available in: Atom PDF