Bug report #13290

Zipped Shape result "not valid"

Added by Adriano Borgobello about 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Browser
Affected QGIS version:2.10.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21348

Description

I've some zipped shape file that I can't add to layers with QGIS 2.8 or 10.10, but worked fine on QGIS 2.2 (didn't try other versions). I've lurked on internet about this problem, but found only something about Preference setting to base or complete .zip scan, and nothing helped.
QGIS files made with QGIS 2.2 and already some reference to zipped shape, work without problems, but I can't add other zipped Shape.
I had to upgrade QGIS because 2.2 seems to have some issue with Mac OS 10.9.5 wich I recently installed in place of OS X 10.8.5.

History

#1 Updated by Harrissou Santanna about 4 years ago

Hi,
I neither can add zipped shape files through "add vector Layer" tool though I think I've done it long time ago.
Meanwhile, you can add zipped file through the Browser Panel in QGIS Desktop (you can activate it with a right click on any toolbar or panel).

#2 Updated by Adriano Borgobello about 4 years ago

Yes, I confirm that this workaround works for me too (thanks for it). But that is, a workaround (that confirms my zipped shapes are ok); I hope that the developers consider to remove the bug at all.

#3 Updated by Saber Razmjooei about 4 years ago

  • Priority changed from High to Normal
  • Status changed from Open to Feedback

Works fine for me under windows and gdal/ogr 1.11.2 for 2.8, 2.10 and master.

#4 Updated by Saber Razmjooei almost 4 years ago

  • Assignee deleted (Adriano Borgobello)
  • Category set to Browser
  • Status changed from Feedback to Open
  • OS version deleted (10.9.5)
  • Operating System deleted (Mac OS X)
  • Target version changed from Version 2.10 to Future Release - Nice to have

It works with Add layer but not in the browser.

#5 Updated by Harrissou Santanna almost 4 years ago

Are you sure, @Saber Razmjooei?
I just test on master df30571 and it's still impossible to add a layer from a zip file with "add a layer" tool. It works fine with the browser panel.

#6 Updated by Saber Razmjooei over 3 years ago

  • Status changed from Open to Closed

Works fine from the browser and add layer in the latest master.

Also available in: Atom PDF