Bug report #13272

crash on quit

Added by Roberto BobMaX about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System:Windows and MacOSX Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:21332

Description

On Windows (7 or others) QGIS crashes with minidump when quit.

It happens also without plugins.
Deleting .qgis2 dir the problem seems to be solved, but some time after it appears again.

Randomically, it crashes also QGIS MacOSX (there is no minidump, but other messages).

qgis-20150827-091710-6764-5396-1b929ef_minidump.zip (4.11 MB) Roberto BobMaX, 2015-08-27 12:35 AM


Related issues

Related to QGIS Application - Bug report #13103: Crash dumped when QGIS close Closed 2015-07-09

History

#1 Updated by Roberto BobMaX about 5 years ago

Image, where I run QGIS without plugins, and it crashes on quit (also with no activity done):

https://drive.google.com/file/d/0Bwg_m86uaXY1LXRvSGV2WE9uZjg/view?usp=sharing

#3 Updated by Sandro Santilli about 5 years ago

What's the affected version ? Can you get a backtrace from the dump ?
Note that on unix you can prevent the creation of dumps (if that bothers you) using ulimit -c 0

#4 Updated by Jürgen Fischer about 5 years ago

Sandro Santilli wrote:

What's the affected version ? Can you get a backtrace from the dump ?
Note that on unix you can prevent the creation of dumps (if that bothers you) using ulimit -c 0

qgis-20150827-091710-6764-5396- 1b929ef _minidump.zip

#5 Updated by Roberto BobMaX about 5 years ago

I used QGIS Pisa 2.10.1 on Windows 7 64 bit.

But, I had this minidump problem from QGIS 2.0.1

And, I know, many others have these (thousand of) minidumps :(

Sometimes, it crashes during layer editing, losing all changes.

Honestly, you do not ever ?

#6 Updated by Salvatore Larosa about 5 years ago

  • Status changed from Open to Feedback

I am a little bit confused....

Which the version affected is? (ok, I see it is since 2.0, but it is no longer candidate for backporting)
2.8.2-3 or 2.10.1 ? (the attache image is referred to 2.8.2 and even the minidump) Could you reproduce the crash with 2.10.1 version (or 2.8.3)?

Platform MacOSX should to throw a more verbose backtrace, could you reproduce the crash and paste the stacktrace of the OSX system?

Thanks for your feedback.

#7 Updated by Roberto BobMaX about 5 years ago

I want to dissolve your doubts.

I have (indeed, we all have) the minidump messages from QGIS 2.0.1 version (that is, if I remember well, the first with multithreading in viewing ).

The minidump problem continues since QGIS 2.10, today, uninterruptedly, and

it also occurs by completely disabling the plugin.

Only deleting the .qgis2 directory, the problem seems to disappear, but after some time occurs again (repeat: also without python plugins).

The peak happens if you run an older version of QGIS (especially the 2.6) before using again the version 2.10.

I am not alone in which this happens, but it is a widespread problem among users.

As soon as possible, I send messages on MacOSX, when I will experience a crash, however, Windows 7 64-bit I became a regular message.

Update: here there is a MacOSX crash report I had with QGIS:

https://drive.google.com/file/d/0Bwg_m86uaXY1M0dmdFpnMTRrZVU/view?usp=sharing

I hope this can be useful to your debug.

Regards

Roberto

#8 Updated by Salvatore Larosa about 5 years ago

Roberto BobMaX wrote:

I want to dissolve your doubts.

I have (indeed, we all have) the minidump messages from QGIS 2.0.1 version (that is, if I remember well, the first with multithreading in viewing ).

Multithreading is landed since 2.4 version.

The minidump problem continues since QGIS 2.10, today, uninterruptedly, and

it also occurs by completely disabling the plugin.

Unfortunately your statements are too generic for the bug tracker but it may be very useful if you'd manage to send a very small project (.qgs) to reproduce the crash which will help a lot the developers to solve the issue.

Only deleting the .qgis2 directory, the problem seems to disappear, but after some time occurs again (repeat: also without python plugins).

The peak happens if you run an older version of QGIS (especially the 2.6) before using again the version 2.10.

I am not alone in which this happens, but it is a widespread problem among users.

As soon as possible, I send messages on MacOSX, when I will experience a crash, however, Windows 7 64-bit I became a regular message.

Thanks, once you get the crash report back the stacktrace message, I'm 99% sure anyone take in account it in order to make happy everybody again!

#9 Updated by Jürgen Fischer about 5 years ago

  • Subject changed from minidump to crash on quit

What in your .qgis2 and what the difference between .qgis2 in the state where it causes the crash and a clean one? You could try to regularly backup .qgis2 until it's broken again, then verify that it actually causes the crash by renaming the last bad copy and renaming the last good one to .qgis2. Comparing the good and bad copy might then give an insight what's actually causing the problem.

#10 Updated by Giovanni Manghi about 5 years ago

please note that there are 3rdparty plugins known to crash qgis even when disabled in the plugin manager (even after restarting qgis).

#11 Updated by Giovanni Manghi almost 5 years ago

  • Target version deleted (Version 2.10)

#12 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

Closing for lack of feedback. Reopen if necessary.

#13 Updated by Roberto BobMaX almost 5 years ago

Update: here there is a MacOSX crash report I had with QGIS:

https://drive.google.com/file/d/0Bwg_m86uaXY1M0dmdFpnMTRrZVU/view?usp=sharing

I hope this can be useful to your debug.

Regards

Roberto

Also available in: Atom PDF