Feature request #1324

Identify on multipoint layer displays useless derived x and y values

Added by Steven Mizuno about 12 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Magnus Homann
Category:Vectors
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:11384

Description

When Identifying a multipoint object the results window shows derived values x=0 and y=0 which is meaningless.

Consider not displaying anything. Alternatively, display component points' x,y values, but this is not a good idea when there are more than a few component points.

multipoint.zip - shapefiles of type multipoint (1.01 KB) Steven Mizuno, 2008-10-22 08:08 PM

identify_derived_multi_geom.diff Magnifier (1.76 KB) Jeremy Palmer, 2010-05-11 03:21 PM

History

#1 Updated by Magnus Homann about 12 years ago

  • Status changed from Open to In Progress

Can you provide a sample multi-point vector, please?

#2 Updated by Steven Mizuno about 12 years ago

Replying to [comment:1 homann]:

Can you provide a sample multi-point vector, please?

The shapefile in the .zip archive contains a few points near 500000, 5000000 in epsg:26915. This was exported from PostGIS.

#3 Updated by Jeremy Palmer over 10 years ago

I have attached a patch that ensures that multi-line and multi-point features do not show any derived information in the identify tool.

#4 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

applied in a78b51e3 (SVN r13472). Thanks.

Also available in: Atom PDF