Bug report #13202

Data (Mapinfo?) related QGIS crash when saving project (NOT in qgis 1.8 though)

Added by Richard Duivenvoorde about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21263

Description

Funny issue: loading (attached) mapinfo data in current QGIS: ok. Save the project: crash!

Then compiled QGIS 1.8: loading and saving/reloading the project: OK

Then loading this 1.8 project in master, and try to save: crash! leaving me with an empty project file...

After every crash the project file is empty.

Note that loading the file is ok: you can see and style it, there is a crash when you save the project.

Tried to save the data as shapefile but then the shapefile makes QGIS crash!

With me on Debian self compiled master and 1.8 here... could be OGR related, or just wrong data, but maybe it is just me.

Would be nicer if we sent an error instead of instant crash, even with faulty data.

Hopefully anybody dan confirm...

kadgrenzen.zip - mapinfo data (5.22 KB) Richard Duivenvoorde, 2015-08-10 10:47 AM

History

#2 Updated by Richard Duivenvoorde about 5 years ago

Yikes... after a fresh compile/install/restart... all is ok. No crashes anymore.

Ik anybody is willing to test, feel free, if not just close it..

#3 Updated by Harrissou Santanna about 5 years ago

Hi,
Richard, do you mean QGIS 2.8 or 1.8?
I tried your data between master and 2.8.3 projects and couldn't reproduce a bug. With 2.8, I got a project crash once, the first time I close the project without saving it but I couldn't reproduce it later. Not sure if it's related to the data.

#4 Updated by Richard Duivenvoorde about 5 years ago

  • Status changed from Open to Closed

Hi, not I really compiled 1.8, but I had crashes with both 1.8, 2.10 and master. If you had no problem I will close this, as I think it was a local library/update problem.

Thanks for checking

Also available in: Atom PDF