Bug report #13160

Web menu inkl. OpenLayers plugin is hidden in QGIS 2.10.1-Pisa when many plugins are activated

Added by Tobias Preuss over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Etienne Tourigny
Category:Python plugins
Affected QGIS version:2.10.0 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21223

Description

Problem

I noticed that the menu item Web disappears when many plugins are installed and activated.
In my case I was searching for the OpenLayers entry but I could not find the Web menu at all.

Workaround

After some experiments I noticed that I can restore the Web menu when I disable most of the other plugins.

QGIS2101-without-web.png - QGIS 2.10.1 without Web menu (100 KB) Tobias Preuss, 2015-07-27 08:36 AM

QGIS2101-many-plugins.png - QGIS 2.10.1 with many plugins activated (141 KB) Tobias Preuss, 2015-07-27 08:36 AM

QGIS2101-with-web.png - QGIS 2.10.1 with Web menu (80 KB) Tobias Preuss, 2015-07-27 08:36 AM

QGIS2101-a-few-plugins.png - QGIS 2.10.1 with a few plugins activated (128 KB) Tobias Preuss, 2015-07-27 08:36 AM

History

#1 Updated by Tobias Preuss over 4 years ago

  • Assignee set to Etienne Tourigny

I figured out that the problem can be reproduced even when QuickOSM is the only activated plugin. You have to restart QGIS once after you deactivated all plugins except QuickOSM. Then when QGIS is restarted the "Web" menu item is gone.

#2 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

So it seems an issue caused by the quickosm plugin... file the ticket in the proper tracker

https://github.com/3liz/QuickOSM/issues

thanks!

#3 Updated by Tobias Preuss over 4 years ago

@Giovanni: Thank you for the link.
I reported the bug here: Web menu is hidden in QGIS 2.10.1-Pisa when QuickOSM is activated

Also available in: Atom PDF