Bug report #13148

Netcdf files : computational problem with the gdal tools

Added by diane peyrot about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Rasters
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21211

Description

Hello,
I'm working at the oceanographic center in France near Toulouse and I'm developing a SIG interface suitable for oceanographers. We have chosen QGIS for it. All files are netcdf files and I use the plugin "netcdf browser" to display it. The netcdf files is composed by several metadata and especially by a scale factor data and an offset data. I realize that QGIS and the GDAL platform can not handle this data automatically. For example, when I want to convert the temperature in kelvin degree to celsius degree, I have to calculate manually the offset and the scale factor with the help of the raster calculator to see the good values of the variable's file (expression for example: (([email protected] scale factor)+offset)-273.15). If I only do the conversion (), I have inconsistent values. I have to repeat this task each time I want to display or analyze any files. It is the same thing for the other physic variables (sea surface height (ssh) and speed current (U+V). Indeed, I have to create a new layer including the scale factor and the offset before making analysis.

I would like to know if the problem comes from the GDAL Tools or from netcdf files and if it can be solved by the community of QGIS?
Thank you for your kindness, I stand available if you need more information.

PS: I'm sorry because I wanted to send you a netcdf file but it is to heavy (150 Mo). Can I send you by an other way like Dropbox?

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Operating System deleted (GDAL Tools)
  • Status changed from Open to Feedback
  • Category changed from GDAL Tools to Rasters
  • OS version deleted (2.6)
  • Target version deleted (Future Release - Nice to have)

Feel free to link a sample using dropbox, it would certainly help.
Then I would also try 2.8/2.10, of I'm not wrong there have been fixes/improvements since 2.6 regarding this format.

I would also raise the question on the user/developers mailing lists, to try understand where is the problem, gdal or qgis.

#2 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

without further details and a dataset is impossible to troubleshoot this issue. Feel free to reopen.

Also available in: Atom PDF