Bug report #13091

Unexpected behaviour in QGIS when saving the duplicate of a point shape

Added by Jan Becker about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Legend
Affected QGIS version:2.10.0 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21158

Description

Hello everyone,

I recognized an unexpexted behaviour in QGIS. I have a point shape and needed a copy of it to delete some points for some analyzing. When I finished editing the copy I was saving it and realized that it overwrites the original shape.

Here is what I did:

1. I loaded a point shape.
2. I duplicate the layer by left clicking on the layer and choosing 'Duplicate'.
3. I delete some points in the duplicated layer and finish it by clicking 'Save layer edits'.
4. When I refresh, the changes are also done for the original layer.

I know that I just create a duplicate of the layer and not the data, but I guess it would be better to have an option that asks if you want to overwrite the original shape file or if you want to save the duplicate as a new. Otherwise it is irritating and giving an unexpexted behaviour.

Best regards

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed
  • Category changed from Browser to Map Legend

As you said "duplicate" means duplicating the layer in the project, not duplicating the datasource. Please file a feature request instead. Cheers!

Also available in: Atom PDF